Problema con urls y TinyMCE en PHP

Al utilizar Tinymce en PHP tenia un inconveniente al utilizar los enlaces y las imágenes que se creaban desde el editor avanzado. Con un poco de reingenieria me di cuenta que al sacar el contenido de la BD las url me quedaban con in "’" antes de las dobles comillas, aunque en la BD se encontraran sin la misma. Por ello, al sacar el contenido el editor se la pegaba.

Pasando el texto a la función stripcslashes de PHP, se eliminan estos backslash y el editor funciona de maravilla. Lo mismo que las imágenes. La versión de editor que uso es la 3.0.1 con el compresor de PHP.


  1. SOS UN CAPOOOO!! JUSTO LO QUE ME STABA PASANDO A MI TMB!!!!! QUE BUENOQ UE LA GENTE COMPARTA SUS EXPRIENCAIS!!!

    DE NUEVO… CAPOOOOOO😀

  2. percy

    Lo k necesitava gracias man Uffff🙂

  3. marcela

    Si eso queda bien, insertas el link, grabas, haces un stripslashes y todo ok. pero si editas el texto (sin modificar los links) y grabas, se vuelve a desarmar el link ……

  4. Jose

    Un saludo grande colega y muy buena ayuda, justo lo que estaba buscando.




Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s



A %d blogueros les gusta esto: